QT Library on MacOS/OSX will not install cannot find old versions of Xcode

I could not get the QT installer to work at all on MacOS 10.14 Mojave, It kept giving errors saying that the Xcode 5 (and some other old non-downloadable version of Xcode was missing. As a result it would not give me a list of QT versions/components to install…

Apparently QT is still trying to find Xcode in:

/Developer/Xcode.app/Contents/Developer

Apple no longer installs Xcode here. The new directory is

/Applications/Xcode.app/Contents/Developer

sudo /usr/bin/xcode-select -switch /Applications/Xcode.app/Contents/Developer

Details of this issue can be found as a bug for Qt 5.2 – Qt Bug 31878 description.

Add a Comment

Your email address will not be published. Required fields are marked *

WordPress Anti-Spam by WP-SpamShield