Hayward Swimpure Plus is a shoddy POS…

2012/03

Ok, every year I have the same problem. The green lights on my Hayward salt generator go off. The display stays on telling me how much salt is in the pool, but the lights will not come on. Usually when I first notice this I can turn off the generator for a little while then the green power light will come back on for a while then when I turn the generator on, the relay will click, then all the led lights go dead again.

This is due to Goldline controls horrible design where a current inrush limiter goes bad and kills the power stage on the primary board.

Here are some links for this issue:

TroublefreePool

YouTubeVideo

Another user’s site with pics and descr

I’ve stolen a few pics from the last user site (just in case he pulls it down)

ametherm-sl322r025 aquariteboardremoval aquaritevaristorcloseup

 

 

 

 

 

 

 

 

 

Here is my post from a popular pool forum:

First off I’m a little ticked at Hayward/GoldLine for continuing production of a faulty design. From the number of people complaining about this, it is not an isolated issue with my board. The only justification I can think of is that they love to sell those $400 boards as a result of the shoddy design. As a result, I have had to replace my inrush limiter once every year.

It may have something to do with my cell being the biggest the system can handle (T.15 for a 40k pool, I think). It always seems to happen after the first of the year when the pool has been too cold for the generator to run, then I run Super Chlorinate for a full day to catch up. I think this overheats the inrush limiter.

Last year I replaced the original AS32-2R025 (DigiKey 570-1105-ND) with a AS35-2R035 (Digikey 570-1112-ND). The resistance at full current was a little lower, but not far off and the part was built to run 35 amps as opposed to the OEM 25 amp… It seems that the AS35 upgrade did not fix the issue.

Update 2013:

Here we are at the beginning of another year and I’m replacing the inrush limiter again because of the same reasons…

This year I’m going with a MS series part MS32-2R035 (Digikey 570-1027-ND). Just replaced it this morning and everything is back up again.

Update 2014:

So far all is well the generator has been running fine since last year. I have not pulled the board off to see if I find any delamination on the inrush limiter part. But Everything appears normal so far. If I were giving advice I’d say to: Replace the AS32-2R025 (DigiKey 570-1105-ND) with a MS32-2R035 (Digikey 570-1027-ND). However, my decision to modify my unit was entirely my decision. If you choose to modify yours, it will be your decision. You should not take advice from me without performing your own assessment and reaching your own conclusion. Additionally, anyone who decides to do such a thing should have the work done by someone who, at least, knows how to solder…

Update 2017:

So I haven’t updated this for a while, sorry…  The system is still working fine. Where replacing the inrush limiter had become a yearly event, the beefier part has been operating without issue for 4 years now 🙂

Update 2018:

Still no issues. 5 years and counting.

19 Comments

Add a Comment

Your email address will not be published. Required fields are marked *

WordPress Anti-Spam by WP-SpamShield